Technical information and announcements about our Christian forums.

Major Sitewide Update - 11/20/2016

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Major Sitewide Update - 11/20/2016

    Major sitewide update. Lots of changes. Most of our templates will not be available until three more days. Here are some of the updates that were implemented:

    Page Manager
    A Page Manager has been added to SiteBuilder. This first iteration is pretty basic. It lists all custom pages and channels and links to them for editing or deletion. This will be handy if you forget the route to a page or simply want to see what you or other administrators have created. Please give your feedback on this new feature so we can make it more robust in the future. This tool can be accessed by choosing the "Pages" option in SiteBuilder.

    SiteBuilder Menu
    Along with adding the Page Manager, a few other changes have been made to the SiteBuilder Menu. The Channel Manager link has been shortened to Channels. The Styles tool has been moved to the left most position for better flow in the menu.

    vBulletin Messenger
    Enhancements have been made to the AJAX polling in vBulletin Messenger to reduce server load. Along with this, there is a new option to allow Administrators to control how many Messenger chats appear on the Messages Dropdown menu. Messenger menus have also been refactored to use the vBulletin Responsive Menu component introduced in vBulletin 5.2.4.

    Image Uploads
    In order to handle an increasing number of metadata tags added to images by smartphones and cameras, image handling has been reworked. Most images that fail our internet security checks will be rewritten before storage. These images will have the majority of their metadata stripped upon saving. This allows us to prevent executable code from being embedded in images will providing support for a larger number of devices.

    Caveats
    • If your site needs support for Animated GIF images that are uploaded, you must use the ImageMagick library under Settings -> Options -> Image Settings. This will require that the ImageMagick executable is installed on your server and the exec() function is not blocked in your PHP settings. Contact your host if you need help setting up ImageMagick.
    • JPEG is a "Lossy" format. Converting JPEG images will result in a slight quality loss. This is currently unavoidable.

    God bless,
    William

  • #2
    Hey, William. When I click on the Home link at the top I get a system error message. Not sure if the link is broken or possibly the home page itself.
    Comment>

    • #3
      Originally posted by Knotical View Post
      Hey, William. When I click on the Home link at the top I get a system error message. Not sure if the link is broken or possibly the home page itself.
      Hi Knotical,

      I just tried three different browsers and the link works fine. Could you try to clear your browser's cache? You can also hit and hold down the control and F5 keys when viewing the home page, that should release and clear the cache.

      And Tapatalk is down until they release their update. Should be very soon.

      God bless,
      William
      Comment>

      • #4
        It must have been a problem with my work computer, because it works just fine at home.

        I haven't used tapatalk for while now, especially since you launched the dedicated app.

        BTW, what happened to the themes?
        Comment>

        • #5
          Originally posted by Knotical View Post
          It must have been a problem with my work computer, because it works just fine at home.

          I haven't used tapatalk for while now, especially since you launched the dedicated app.

          BTW, what happened to the themes?
          The themes are awaiting updates. The main software forum was updated, and themes and mobile apps are next. Should be within the week that things are back up and running as were. However, I just came upon one new bug, when uploading an image it produces a server error. Reporting the issue now.

          God bless,
          William
          Comment>

          • #6
            Originally posted by William View Post

            The themes are awaiting updates. The main software forum was updated, and themes and mobile apps are next. Should be within the week that things are back up and running as were. However, I just came upon one new bug, when uploading an image it produces a server error. Reporting the issue now.

            God bless,
            William
            The image uploader does work fine, I had to clear my cache too! :o

            God bless,
            William
            Comment>

            • #7
              Not a yuge issue, but when I go to the Activity page, the window that has a list of the recent activity takes forever to load, if at all.
              Comment>

              • #8
                Originally posted by Knotical View Post
                Not a yuge issue, but when I go to the Activity page, the window that has a list of the recent activity takes forever to load, if at all.
                Still sounds like a cache issue. If you are able to clear the cache I recommend so. The Activity page takes less than two seconds for it to load in its entirety on my end.

                I also have just updated the custom "Faith" template and it's now running as default.

                Also received word from Tapatalk, and our mobile apps which are done through them are currently being updated. I'll post the status once the mobile apps are up and running again.

                God bless,
                William
                Comment>

                • #9
                  Tried clearing the cache, but still not loading properly, if at all. It could just be my work computer. I will check again after I get home.
                  Comment>

                  • #10
                    Originally posted by Knotical View Post
                    Tried clearing the cache, but still not loading properly, if at all. It could just be my work computer. I will check again after I get home.
                    Just curious, which browser is your work computer using? Is there another browser from the same computer that can be used to test? I just tried Firefox, Chrome, Edge, and Brave with no problems.

                    God bless,
                    William
                    Comment>

                    • #11
                      I use Chrome whenever I can. I did try the ctrl-f5 maneuver, but to no avail.
                      Comment>

                      • #12
                        Originally posted by Knotical View Post
                        I use Chrome whenever I can. I did try the ctrl-f5 maneuver, but to no avail.
                        Some browsers will not release and clear cache with control f-5. It'll only refresh the page. When I work with the website this is a pain, because sometimes I can't see my changes until I do a hard cache clear. The problem you're having happened to me after I added the Facebook like etc on the left side of the page. The issue was resolved after having cleared the cache. With all the changes made this week to the site most problems will go away after clearing the cache.

                        God bless,
                        William
                        Comment>

                        • #13
                          Originally posted by William View Post

                          Some browsers will not release and clear cache with control f-5. It'll only refresh the page. When I work with the website this is a pain, because sometimes I can't see my changes until I do a hard cache clear. The problem you're having happened to me after I added the Facebook like etc on the left side of the page. The issue was resolved after having cleared the cache. With all the changes made this week to the site most problems will go away after clearing the cache.

                          God bless,
                          William
                          Yeah, that is probably what is going on as I am not having the same issues with my home computer. I will try it again tomorrow when I get to work.
                          Comment>

                          • #14
                            Mobile apps are now working.

                            God bless,
                            William
                            Comment>
                            Working...
                            X
                            Articles - News - SiteMap